Suivez-nous

Actualités

Les applications iPhone / iPod Touch soumises à Apple doivent désormais être compatibles Firmware 3

Il y a

 

le

 

Le Firmware 3 qui va sortir début Juin en
est
à sa beta 5
et se précise. C’est le moment qu’a choisi Apple pour imposer
aux développeurs de ne désormais soumettre que des applications compatibles
avec ce nouveau Firmware.

Il s’agit en effet d’une version majeure du système d’exploitation
de l’iPhone / iPod Touch
et manifestement Apple ne veut pas se
retrouver avec des applications non compatibles avec son logiciel lors de sa
sortie
. Voici le contenu de la communication envoyée aux développeurs
(cliquer pour agrandir):

iphone-firmware-3-obligatoire.jpg

Si l’on comprend bien la démarche, voici une nouvelle contrainte pour les
développeurs : installer et tester absolument son logiciel avec la
dernière version beta du Firmware 3
sous peine de ne plus
pouvoir sortir de mise à jour d’ici le mois de Juin
.

En outre, Apple annonce queles anciennes applications non
compatibles avec le nouveau Firmware lors de sa sortie, seront
supprimées de l’AppStore
. Ceci pose la question : est-ce que
Apple parle des applis non utilisables avec le nouvel OS ou de
celles non compilées avec les dernières librairies ?
Apparemment tout n’estpas encore très clair …

Développeurs : avez vous du modifier votre application pour le
Firmware 3 ou celui-ci est ‘compatible ascendant’ sans problèmes notables pour
vous ?


Source

i-nfo.fr - App officielle iPhon.fr
Par : Keleops AG
4.4 / 5
16,2 k avis
21 Commentaires

21 Commentaires

  1. Seagull

    11 mai 2009 à 16 h 19 min

    Pourquoi pas 1$ symbolique ?

  2. Ondelight

    11 mai 2009 à 17 h 33 min

    La traduction avec quelques modifications :

    LES NOUVELLES SOUMISSIONS A L’APP STORE DEVRONT ETRE COMPATIBLE AVEC LE
    FIRMWARE 3.0
    Testez votre application avec le firmware 3.0 Bêta 5 dès maintenant.

    Toutes les applications doivent être compatible avec l’Iphone 3.0
    Des millions d’Iphones et Ipod Touch vont être mis a jour pour l’Iphone OS 3.0
    cet
    été. A partir d’aujourd’hui, toutes les soumissions a l’App Store devront être
    compatible avec la dernière bêta de l’Iphone 3.0. Si votre application n’est
    pas compatible, elle sera rejeté.

    Il existe des applications dans l’App Store qui devrait être compatible avec
    l’OS 3.0 sans modification, mais vous devrez les tester avec l’Iphone 3.0 pour
    savoir si elles sont compatibles. Lorsque l’iPhone OS 3.0 final sera sorti pour
    tout les utilisateurs , toute application non compatible avec l’iPhone OS 3.0
    sera probablement retirée

  3. Geraud.ch

    11 mai 2009 à 13 h 15 min

    Hello,
    Je suis développeur aussi. En fait il faut comprendre autrement: actuellement
    on peut "fabriquer" l’application pour l’OS 2.0 et elle est aussi compatible
    avec l’OS 2.1.Là c’est pareil, on peut la "fabriquer" pour l’OS 2.0 mais il
    faut vérifier qu’elle fonctionne bien pour OS3.

    Les applications que j’ai développées sont quasiment toutes compatibles avec
    OS3. On a juste eu une petite modif à faire pour l’une d’elles.

  4. lplassart

    11 mai 2009 à 15 h 13 min

    @Dupont

    Depuis qu’Apple est une société Américaine et est soumise à la fiscalité
    Américaine…
    Pour faire (très, très) basique: l’entreprise n’a pas le droit d’ajouter des
    fonctionnalités supplémentaires sans les facturer.
    Pour l’iPhone, Apple percevant une dîme mensuelle des opérateurs, l’ajout de
    nouvelles fonctionnalités est donc considéré comme "facturé".
    Pour l’iPod Touch, une fois le paiement effectué à l’achat de l’appareil, il
    n’y a pas de mensualité. Donc il est impératif pour Apple de facturer l’ajout
    de nouvelles fonctionnalités.

  5. Julien

    11 mai 2009 à 11 h 46 min

    Je trouve que c’est une bonne démarche…

    Je dis pas ça pour troller mais ça permet d’éviter des fiascos comme la
    sortie de Vista, avec rien de compatible…

    PS : Ça c’est arrangé par la suite pour Vista, mais les premiers mois ont
    été pour le moins laborieux !

  6. Iphone59

    11 mai 2009 à 12 h 13 min

    Je traduis:

    LES NOUVELLES SOUMISSIONS A L’APP STORE DEVRONT ETRE COMPATIBLE AVEC LE
    FIRMWARE 3.0
    Testez votre application avec le firmware 3.0 Bêta 5 dès maintenant.

    Toutes les applications doivent être compatible avec l’Iphone 3.0
    Des millions d’Iphones et Ipod Touch vont être mis a jour pour l’Iphone OS 3.0
    cet
    été. A partir d’aujourd’hui, toutes les soumissions a l’App Store devront être
    compatible avec La dernière bêta de l’Iphone 3.0. Si votre application n’est
    pas compatible, elle sera rejeté.

    Il existe des applications dans l’App Store qui devrait être compatible avec
    l’OS 3.0 sans modification, mais vous devrez tester cela avec l’Iphone 3.0 pour
    être sur que c’est compatible ou non. Après que l’Iphone 3.0 arrive
    définitivement pour les utilisateurs, toute application qui est incompatible
    avec l’OS 3.0 sera supprimé de l’App Store.

  7. Sigmanet15

    11 mai 2009 à 13 h 24 min

    Hello, je suis moi aussi développeur.
    Pour nous c’est tout bon. Nos applications sont toutes compatibles 3.0 beta 5
    !
    Il semble que si l’appli est bien codée dès le départ, la compatibilité est
    assurée ! Soulagement !

  8. robert

    11 mai 2009 à 11 h 48 min

    Là au moins on se pose plus la question d’attendre ou pas, pour passer à au
    framework 3 !

  9. Dupont

    11 mai 2009 à 12 h 14 min

    "C’est dû à une loi américaine."

    Depuis quand que les lois américaines s’appliquent en France.

  10. Sigmanet15

    11 mai 2009 à 13 h 24 min

    Hello, je suis moi aussi développeur.
    Pour nous c’est tout bon. Nos applications sont toutes compatibles 3.0 beta 5
    !
    Il semble que si l’appli est bien codée dès le départ, la compatibilité est
    assurée ! Soulagement !

  11. Skippy

    11 mai 2009 à 11 h 54 min

    "may be removed" …

    en français : "pourrait être retirées"

    Ce n’est pas encore clair de ce coté.
    Ce que je ne trouve pas "normal" c’est d’imposer le firmware 3.0 alors qu’il
    sera payant sur iPod Touch.

    Vu les améliorations principalement orientées iPhone, il est probable qu’un
    grand nombre de possesseurs d’iTouch vont faire l’impasse sur cette mise à
    jour.

    Si les mise à jours et/ou nouvelles applications sont uniquement compatibles
    OS 3.0, Apple oblige une fois de plus ses "cher" client iTouch à casquer (j’ai
    déjà payer pour la 2.0 !!) (ou a pirater, ce qui n’est pas mieux)

  12. lplassart

    11 mai 2009 à 11 h 58 min

    @Skippy

    Rien ne t’oblige à mettre à jour ton iPod Touch, les applications ne vont
    pas disparaître de ton appareil…
    Et, au risque de répéter une information largement diffusée, ce n’est Apple qui
    a décidé de faire payer les mises à jour sur l’iPod Touch. C’est dû à une loi
    américaine.

  13. Hi

    11 mai 2009 à 12 h 29 min

    La traduction d’Iphone59 est presque parfaite.

    Si je résume, tous les développeurs doivent acheter le SDK 3.0 pour 99 $
    s’ils veulent que leurs applications reste sur l’AppStore.

    Encore un bon coup stratégique pour Apple.

  14. robert

    11 mai 2009 à 12 h 48 min

    Ils n’ont pas à l’acheter! à partir du moment que tu as le statut de
    développeur, tu as automatiquement accès au SDK pour le firmware 3, ainsi que
    le firmware 3 pour ton iPhone de développement…

  15. sparkle59

    11 mai 2009 à 12 h 58 min

    Bonjour à tous.
    Je suis le développeur de WhatToCook?.
    La dernière version actuelle fonctionne parfaitement sur le firmware 3.0 beta
    5. J’imagine que bcp d’apps resteront compatibles.

  16. Matthieu

    11 mai 2009 à 16 h 32 min

    Bon ben moi j’ai du pédicoder car j’ai des fonctionnalités qui
    merdouillent…
    Le plus inquiétant est surement le délai de validation par Apple qui va
    nettement s’allonger.

    Pour répondre à la question du post – ce sont les applis non utilisables
    avec l’OS 3 qui seront supprimées…il ne sera pas obligatoire pour les devs de
    compiler avec le SDK 3
    En passant j’ai lu sur le forum dev d’apple que depuis la semaine derniere
    toutes les applications envoyées sur le store sont testées avec la Beta 5.

  17. Skippy

    11 mai 2009 à 17 h 37 min

    Mais je crois que je m’égare … l’OS 3.0 oui mais … faut voir 😉

  18. Damtux

    12 mai 2009 à 1 h 18 min

    Je vois que souvent pense qu’il faut passer au firmware 3 pour utiliser les
    prochaines application qui vont sortie. C’est pas du tout le cas, faut juste
    adapter l’application afin quel fonctionne parfaitement avec l’OS 3.0. Donc
    clairement, elle marcheront avec le 2.xx et 3.x

  19. Skippy

    11 mai 2009 à 17 h 36 min

    +1000 pour Seagull

    S’il y a "obligation" de facturer, ils peuvent peut être arrêter de prendre
    le client pour un bovin amical et domestiqué et faire dans le symbolique.

    L’air de rien, mon iPod touch v1 32Go a quand même du rapporter quelques $$$
    à la pomme (sur les 439€ que j’ai payé)

  20. Sam

    11 mai 2009 à 18 h 04 min

    @ Skippy:

    Peut être que le prix facturé, correspond également à une taxe prélevée? Si
    quelqu’un à plus d’infos.

    Par contre si c’est effectivement un montant librement fixé par Apple, c’est
    clair que c’est pas très "correct".

    Pour mon infos, combien avait coûté le passage au firmware 2?

  21. Ivy

    11 mai 2009 à 23 h 00 min

    Moi je me demande: si une appli n’est pas "compatible" avec l’OS 3.0 parce
    que c’est un bug de l’OS (il est en Bêta 5, mais c’est quand même une Bêta),
    qu’est-ce qu’on doit faire ? Modifier l’appli pour contourner le bug de la Bêta
    ou attendre la sortie de la prochaine Bêta pour voir si le bug est corrigé
    ?

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *